Форум обсуждения систем  

Вернуться   Форум обсуждения систем "Умный дом", проектов Ардуино, OpenWRT и других DIY устройств > Форум умного дома > Сделай сам > OpenWRT/LEDE

Ответ
 
Опции темы Поиск в этой теме Опции просмотра
Старый 25.07.2014, 11:48   #31
Admin
Administrator
 
Аватар для Admin
 
Регистрация: 12.04.2010
Адрес: Москва
Сообщений: 9,368
Вес репутации: 9567
Admin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant future
По умолчанию Re: VPN и OpenWRT

Питания не хватает
Admin вне форума   Ответить с цитированием
Старый 25.07.2014, 12:56   #32
radiopulsar
Junior Member
 
Регистрация: 25.07.2014
Сообщений: 3
Вес репутации: 0
radiopulsar is an unknown quantity at this point
По умолчанию Re: VPN и OpenWRT

Ему реально 1.5А может не хватать? К роутеру ничего не прицеплено. При увеличении интервала echo-пакетов держит коннект 1.1 мин и тоже валится.
radiopulsar вне форума   Ответить с цитированием
Старый 25.07.2014, 13:11   #33
Admin
Administrator
 
Аватар для Admin
 
Регистрация: 12.04.2010
Адрес: Москва
Сообщений: 9,368
Вес репутации: 9567
Admin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant future
По умолчанию Re: VPN и OpenWRT

На БП указываемый ток, часто не соответствует реальным его значениям
У меня хорошо зарекомендовал себя БП от планшета Nexus 7
Admin вне форума   Ответить с цитированием
Старый 25.07.2014, 13:26   #34
radiopulsar
Junior Member
 
Регистрация: 25.07.2014
Сообщений: 3
Вес репутации: 0
radiopulsar is an unknown quantity at this point
По умолчанию Re: VPN и OpenWRT

Я использую от xperia p. Еще сейчас пробовал от asus vivotab smart, там заявлено 2А. Попробую под нагрузкой измерить ток.
radiopulsar вне форума   Ответить с цитированием
Старый 25.07.2014, 13:47   #35
Admin
Administrator
 
Аватар для Admin
 
Регистрация: 12.04.2010
Адрес: Москва
Сообщений: 9,368
Вес репутации: 9567
Admin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant future
По умолчанию Re: VPN и OpenWRT

Электролитический конденсатор 1000мкФ по питанию может решить проблему
Admin вне форума   Ответить с цитированием
Старый 26.07.2014, 00:41   #36
paulerr
Senior Member
 
Регистрация: 04.01.2013
Адрес: Москва
Сообщений: 433
Вес репутации: 1019
paulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond repute
По умолчанию Re: VPN и OpenWRT

А что говорит техподдержка йоты? Помниться у меня когда был wimax от yota в ноуте, тоже не работал vpn через них. Решилось звонком в техподдержку
paulerr вне форума   Ответить с цитированием
Старый 30.10.2014, 19:11   #37
wanvo
Member
 
Регистрация: 21.11.2013
Сообщений: 44
Вес репутации: 0
wanvo is an unknown quantity at this point
По умолчанию Re: VPN и OpenWRT

А где посмотреть логи pptp соединения?
У меня оно поднимается на несколько секунд, а потом пропадает.
И вроде делал все как раньше, и вроде прошивки те-же самые...
wanvo вне форума   Ответить с цитированием
Старый 06.11.2014, 00:42   #38
wanvo
Member
 
Регистрация: 21.11.2013
Сообщений: 44
Вес репутации: 0
wanvo is an unknown quantity at this point
По умолчанию Re: VPN и OpenWRT

Разобрался с проблемой. Если кто на такие-же "грабли" наступит - пишите в личку, расскажу как решить. А вообще пора на IPV6 переходить
wanvo вне форума   Ответить с цитированием
Старый 13.12.2014, 15:19   #39
shai27
Junior Member
 
Регистрация: 06.12.2014
Адрес: СПб
Сообщений: 4
Вес репутации: 0
shai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond repute
По умолчанию Re: VPN и OpenWRT

чистая CyberWrt (слитая 13.12.14)

делаю
opkg update
opkg install ppp-mod-pptp

Код:
root@CyberWrt:/# opkg update
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/Packages.gz.
Updated list of available packages in /var/opkg-lists/cyberwrt_pack.
root@CyberWrt:/# opkg install ppp-mod-pptp
Installing ppp-mod-pptp (2.4.5-10) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/ppp-mod-pptp_2.4.5-10_ar71xx.ipk.
Installing kmod-pptp (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-pptp_3.10.4-1_ar71xx.ipk.
Installing kmod-ppp (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-ppp_3.10.4-1_ar71xx.ipk.
Installing kmod-slhc (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-slhc_3.10.4-1_ar71xx.ipk.
Installing kmod-gre (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-gre_3.10.4-1_ar71xx.ipk.
Installing kmod-ipv6 (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-ipv6_3.10.4-1_ar71xx.ipk.
Installing kmod-iptunnel (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-iptunnel_3.10.4-1_ar71xx.ipk.
Installing kmod-pppox (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-pppox_3.10.4-1_ar71xx.ipk.
Installing kmod-mppe (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-mppe_3.10.4-1_ar71xx.ipk.
Installing kmod-crypto-sha1 (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-crypto-sha1_3.10.4-1_ar71xx.ipk.
Installing kmod-crypto-ecb (3.10.4-1) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/kmod-crypto-ecb_3.10.4-1_ar71xx.ipk.
Installing resolveip (2) to root...
Downloading http://cyberwrt.ru/application/packages/TL-MR3020/1_4/resolveip_2_ar71xx.ipk.
Configuring kmod-ipv6.
Configuring kmod-iptunnel.
Configuring kmod-gre.
Configuring kmod-slhc.
Configuring kmod-ppp.
Configuring kmod-pppox.
Configuring resolveip.
Configuring kmod-pptp.
Configuring kmod-crypto-sha1.
Configuring kmod-crypto-ecb.
Configuring kmod-mppe.
Configuring ppp-mod-pptp.
так-так-так...

Код:
root@CyberWrt:/# opkg list-installed |grep pp*p
kmod-mppe - 3.10.4-1
kmod-ppp - 3.10.4-1
kmod-pppox - 3.10.4-1
kmod-pptp - 3.10.4-1
ppp-mod-pptp - 2.4.5-10
а где сам PPP daemon? из списка http://wiki.openwrt.org/doc/howto/vpn.client.pptp также отсутствуют kmod-pppoe, ppp-mod-pppoe и luci-proto-ppp. Но ppoe мне не нужно, как и luci.

доставляю ppp

Код:
root@CyberWrt:/# opkg install ppp
Installing ppp (2.4.5-10) to root...
Downloading http://cyberwrt.ru/application/packa...-10_ar71xx.ipk.
Configuring ppp.
вот теперь всё на месте

Код:
root@CyberWrt:/# opkg list-installed |grep ppp
kmod-ppp - 3.10.4-1
kmod-pppox - 3.10.4-1
ppp - 2.4.5-10
ppp-mod-pptp - 2.4.5-10
Ребут. Ну, привычка такая, всё-таки я мышевоз гуев =)

редактирую конфиги
Код:
root@CyberWrt:/etc/config# cat /etc/ppp/options.pptp
noipdefault
noauth
nobsdcomp
nodeflate
idle 0
#mppe required,no40,no56,stateless
maxfail 0
refuse-eap

root@CyberWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde5:98e1:5d84::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.100'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'

config interface 'wwan'
        option proto 'static'
        option ipaddr '192.168.100.100'
        option gateway '192.168.1.1'
        option netmask '255.255.255.0'
        option dns '8.8.8.8'

config interface 'vpn'
        option ifname 'pptp-vpn'
        option proto 'pptp'
        option server '89.xxx.xxx.xx'
        option username 'userxxxxxx'
        option password 'pswdxxxxxx'
        option buffering '1'

читаю http://wiki.openwrt.org/doc/howto/vpn.client.pptp

"After restarting network service or rebooting your router, and if your VPN handshake and authentication went well, the pptp-vpn interface will show up as enabled in LuCI. You can also check it using CLI with ifconfig. From your router (not your computer), try to ping some wan address to see if everything is fine and skip to the Routing part bellow".

Ребут. И посмотрим, что там с интерфейсами.

Видимо, ничего, т.к. на VPN сервере входящих подключений нет, а в логах... о, в логах

Код:
Dec 13 14:06:49pptpd[552]CTRL: Client 192.168.1.100 control connection started
Dec 13 14:06:50ndmkernel: fast vpn ctrl: 6401a8c0, 1
Dec 13 14:06:50pptpd[552]CTRL: Starting call (launching pppd, opening GRE)
Dec 13 14:06:50pptp[553]Plugin pptp.so loaded.
Dec 13 14:06:50pptp[553]PPTP plugin version 0.8.3 compiled against pppd 2.4.4
Dec 13 14:06:50pptp[553]pppd 2.4.4 started by root, uid 0
Dec 13 14:06:50pptp[553]Using interface vpn1
Dec 13 14:06:50pptp[553]Connect: vpn1 <--> pptp (192.168.1.100)
Dec 13 14:06:53pptp[553]local IP address 192.168.1.1
Dec 13 14:06:53pptp[553]remote IP address 172.16.1.10
Dec 13 14:06:53pptp[553]MPPE required but cannot negotiate MPPE key length
Dec 13 14:06:53ndmkernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
Dec 13 14:06:53pptp[553]Received bad configure-ack:
Dec 13 14:06:53ndmkernel: ppp: compressor dropped pkt
Dec 13 14:06:56ndmkernel: mppe_decomp_alloc: options rejected: o[0]=12, o[1]=06, o[2]=00, o[3]=00, o[4]=00, o[5]=00
Dec 13 14:06:56pptp[553]LCP terminated by peer (MPPE disabled)
Dec 13 14:06:56pptp[553]Connect time 0.1 minutes.
Dec 13 14:06:56pptp[553]Sent 286 bytes, received 238 bytes.
Dec 13 14:06:56pptpd[552]CTRL: Reaping child PPP[553]
Dec 13 14:06:56pptpd[552]CTRL: Client pppd TERM sending
Dec 13 14:06:56pptpd[552]CTRL: Client pppd finish wait
Dec 13 14:06:56pptp[553]Terminating on signal 15
Dec 13 14:06:59pptp[553]Connection terminated.
Dec 13 14:06:59ndmkernel: fast vpn ctrl: 6401a8c0, 0
Dec 13 14:06:59pptp[553]Modem hangup
Dec 13 14:06:59pptp[553]Exit.
Dec 13 14:06:59pptpd[552]CTRL: Client 192.168.1.100 control connection finished
Курю про MPPE. Шифрование-то мне не нужно, только процы грузить да канал забивать. Однако в /etc/ppp/options.pptp строчка закомментирована #mppe required,no40,no56,stateless. Удалял - эффект тот же, то есть никакого.

Включил шифрование (раскомментировал строку) - завелось. Ладно, разберемся с этим позже. Итак,

Код:
root@CyberWrt:/# cat /etc/ppp/options.pptp
noipdefault
noauth
nobsdcomp
nodeflate
idle 0
maxfail 0
mppe required,no40,no56,stateless
refuse-eap

root@CyberWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr C0:4A:00:F4:56:20
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::c24a:ff:fef4:5620/64 Scope:Link
          inet6 addr: fde5:98e1:5d84::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:264 errors:0 dropped:0 overruns:0 frame:0
          TX packets:230 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:26459 (25.8 KiB)  TX bytes:18759 (18.3 KiB)

eth0      Link encap:Ethernet  HWaddr C0:4A:00:F4:56:20
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:264 errors:0 dropped:0 overruns:0 frame:0
          TX packets:230 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:30155 (29.4 KiB)  TX bytes:18759 (18.3 KiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1648 (1.6 KiB)  TX bytes:1648 (1.6 KiB)

pptp-vpn  Link encap:Point-to-Point Protocol
          inet addr:172.16.1.10  P-t-P:192.168.1.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1350  Metric:1
          RX packets:33 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:1740 (1.6 KiB)  TX bytes:1014 (1014.0 B)

wlan0     Link encap:Ethernet  HWaddr C0:4A:00:F4:56:20
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:15291 (14.9 KiB)

Пингую
Код:
C:\>ping 172.16.1.10 -l 64000

Обмен пакетами с 172.16.1.10 по с 64000 байтами данных:
Ответ от 172.16.1.10: число байт=64000 время=18мс TTL=64
Ответ от 172.16.1.10: число байт=64000 время=18мс TTL=64
Ответ от 172.16.1.10: число байт=64000 время=18мс TTL=64
Ответ от 172.16.1.10: число байт=64000 время=18мс TTL=64

Статистика Ping для 172.16.1.10:
    Пакетов: отправлено = 4, получено = 4, потеряно = 0
    (0% потерь)
Приблизительное время приема-передачи в мс:
    Минимальное = 18мсек, Максимальное = 18 мсек, Среднее = 18 мсек

C:\>
По адресу 172.16.1.10 WEB не открывается, телнет тоже.

Добавляю в /etc/config/network

Код:
config route
	option interface 'vpn'
	option target '172.16.1.0'
	option gateway '192.168.1.1'
	option netmask '255.255.255.0'
и перегружаю. Никакого эффекта.

Вот дальше мне непонятно, что делать.

Во-первых, почему при отключении MPPE не устанавливается связь? В Zyxel'е разрешено подключение без шифрования, и другие клиенты (как виндовые, так и невиндовые) вполне себе цепляются.
Во-вторых, что еще надо добавить в конфиги, чтобы веб-интерфейс был виден по назначенному VPN сервером адресу? Файрвол мне не нужен, NAT, в общем, тоже - этот девайс ничего никуда не роутит, он просто клиент с веб-интерфейсом.


P.S.: Доступно: 888.0K
shai27 вне форума   Ответить с цитированием
Старый 13.12.2014, 17:14   #40
shai27
Junior Member
 
Регистрация: 06.12.2014
Адрес: СПб
Сообщений: 4
Вес репутации: 0
shai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond reputeshai27 has a reputation beyond repute
По умолчанию Re: VPN и OpenWRT

Итак, всё заработало.
Схема сети такая:

Дома установлен Zyxel Keenetic Ultra, имеется фиксированный белый IP. Из коробки поднят VPN сервер, раздает адреса из сети 172.16.1.0/24.
На даче установлен Zyxel Keenetic 4G II, интернет получает от МТС (через разлоченный мегафонский свисток =), раздаёт по WiFi всем желающим адреса из сети 10.10.27.0/24.
Один из клиентов WiFi - MR3020 c CyberWRT, к нему подключена камера. Настройки получает по dhcp, для чего [в 4G II] выдаваемый ip (10.10.27.10) привязан по MAC.
Задача - поднять PPP тоннель и увидеть MR3020 в локальной сети.

Код:
opkg update
opkg install ppp-mod-pptp
opkg install ppp

в /etc/ppp/options.pptp пишем
noipdefault
noauth
nobsdcomp
nodeflate
idle 0
maxfail 0
mppe required,no40,no56,stateless
refuse-eap

в /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde5:98e1:5d84::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'dhcp'

config interface 'wwan'
        option proto 'dhcp'
        option ssid 'myWiFiNetworkSSID'
        option encryption 'psk2'
        option key 'myPasswordForWiFi'

config interface 'vpn'
        option ifname 'pptp-vpn'
        option proto 'pptp'
        option server 'xxx.xxx.xxx.xxx'		#  адрес VPN сервера
        option username 'vpnLogin'			  
        option password 'vpnPassword'		
        option buffering '1'

config route
        option interface 'vpn'
        option target 'yyy.yyy.yyy.0'		# сеть, в которой VPN сервер раздаёт адреса, у меня 172.16.1.0
        option gateway '192.168.1.1'		# адрес шлюза, который отдаёт VPN сервер
        option netmask '255.255.255.0'
Вот и всё, после перезагрузки MR3020 интерфейс поднялся самостоятельно. Прямо через поднятый тоннель был установлен драйвер вебкамеры и пошла картинка. Завтра камера поедет на ПМЖ в деревню =)
shai27 вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 11 (пользователей: 0 , гостей: 11)
 
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 17:52. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot
Яндекс.Метрика