Форум обсуждения систем  

Вернуться   Форум обсуждения систем "Умный дом", проектов Ардуино, OpenWRT и других DIY устройств > Форум умного дома > Сделай сам > OpenWRT/LEDE

Ответ
 
Опции темы Поиск в этой теме Опции просмотра
Старый 02.02.2018, 18:23   #91
sana555
Senior Member
 
Регистрация: 22.09.2017
Сообщений: 338
Вес репутации: 439
sana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to behold
По умолчанию

Цитата:
Сообщение от sunny Посмотреть сообщение
Все равно, начните с 15.05 - той что там:
https://wiki.openwrt.org/toh/hwdata/...us_rt-n18u_220
Угадайте с трех раз какой результат? - Такой же... Еще одна странная особенность, после прошивки в веб интерфейсе осталась надпись LEDE, вместо OpenWrt...
sana555 вне форума   Ответить с цитированием
Старый 02.02.2018, 20:07   #92
sunny
Senior Member
 
Аватар для sunny
 
Регистрация: 22.10.2015
Адрес: Там где сосны и песок
Сообщений: 1,534
Вес репутации: 1598
sunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to all
По умолчанию

Цитата:
Сообщение от sana555 Посмотреть сообщение
Понял, спасибо.
Еще вопрос. Нужно ли выполнять эту команду во время сборки, после выбора своего роутера, нашел в инструкции у "денисюрьев":
Код:
make tools/install -j3 V=-1 && make toolchain/install -j3 V=-1
Нет, там и это можно опустить:
создать дефолтный .config
Код:
make defconfig
проверить все ли необходимые для сборки пакеты установлены на ОС ПК
Код:
make prereq
Ну может вы и шьете как-то по особенному:

Обзор выбрать и т.д.
__________________
Читаю ваши мысли по аватару ...

Последний раз редактировалось sunny; 02.02.2018 в 20:12.
sunny вне форума   Ответить с цитированием
Старый 02.02.2018, 20:33   #93
sana555
Senior Member
 
Регистрация: 22.09.2017
Сообщений: 338
Вес репутации: 439
sana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to behold
По умолчанию

Цитата:
Сообщение от sunny Посмотреть сообщение
Ну может вы и шьете как-то по особенному:
Да нет, так же выбираю..
Только не выполнял команду:
Код:
make defconfig
Поскольку в том мануале ее не было...
sana555 вне форума   Ответить с цитированием
Старый 06.02.2018, 12:22   #94
sana555
Senior Member
 
Регистрация: 22.09.2017
Сообщений: 338
Вес репутации: 439
sana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to behold
По умолчанию

Цитата:
Сообщение от sunny Посмотреть сообщение
создать дефолтный .config
Код:
make defconfig
После выполнения ругается что имеет зависимость от какого то 'flite':

Код:
Collecting package info: done
WARNING: Makefile 'package/feeds/telephony/freeswitch/Makefile' has a dependency on 'flite', which does not exist
#
# configuration written to .config
#
sana555 вне форума   Ответить с цитированием
Старый 06.02.2018, 15:40   #95
sunny
Senior Member
 
Аватар для sunny
 
Регистрация: 22.10.2015
Адрес: Там где сосны и песок
Сообщений: 1,534
Вес репутации: 1598
sunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to all
По умолчанию

Это ставиться под openwrt:
Код:
sudo apt-get install subversion build-essential libncurses5-dev zlib1g-dev gawk flex git-core gcc-multilib gettext qemu-system-mips quilt mercurial bzr cvs libxml-parser-perl cvs libssl-dev xsltproc
Это ставится под lede:
Код:
sudo apt-get install build-essential subversion libncurses5-dev zlib1g-dev gawk gcc-multilib flex git-core gettext libssl-dev
Удовлетворить зависимости:
Код:
sudo apt-get install -f
__________________
Читаю ваши мысли по аватару ...

Последний раз редактировалось sunny; 08.02.2018 в 15:54.
sunny вне форума   Ответить с цитированием
Старый 07.02.2018, 16:18   #96
sana555
Senior Member
 
Регистрация: 22.09.2017
Сообщений: 338
Вес репутации: 439
sana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to behold
По умолчанию

Цитата:
Сообщение от sunny Посмотреть сообщение
Это ставится под lede:
Код:
sudo apt-get install build-essential subversion libncurses5-dev zlib1g-dev gawk gcc-multilib flex git-core gettext libssl-dev
Выполнил эту команду, но все равно та же ошибка..
sana555 вне форума   Ответить с цитированием
Старый 07.02.2018, 16:39   #97
sunny
Senior Member
 
Аватар для sunny
 
Регистрация: 22.10.2015
Адрес: Там где сосны и песок
Сообщений: 1,534
Вес репутации: 1598
sunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to all
По умолчанию

Сначала это:
Код:
sudo apt-get install -f
Потом это
Код:
sudo apt-get install subversion build-essential libncurses5-dev zlib1g-dev gawk flex git-core gcc-multilib gettext qemu-system-mips quilt mercurial bzr cvs libxml-parser-perl cvs libssl-dev xsltproc
Для OpenWrt и lede требуется установить одни и теже пакеты, но список пакетов у openwrt длиннее, проще сразу ставить их
Вот жеж, бедолага
Как "творческие узбеки" ?
__________________
Читаю ваши мысли по аватару ...

Последний раз редактировалось sunny; 08.02.2018 в 15:54.
sunny вне форума   Ответить с цитированием
Старый 08.02.2018, 15:45   #98
sana555
Senior Member
 
Регистрация: 22.09.2017
Сообщений: 338
Вес репутации: 439
sana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to behold
По умолчанию

Цитата:
Сообщение от sunny Посмотреть сообщение
Вот жеж, бедолага
Как "творческие узбеки" ?
Тут еще принтер заполосил, и там и тут узбек крутится.
Ну я не знаю, может быть у меня и вправду не оттуда руки выросли...
Делаю так:
1. Удалил папку source
Далее:
Ваша команда у меня не сработала:
Код:
sudo install -f
Поменял на, вроде сработало:
Код:
sudo apt-get install -f
Далее:
Код:
sudo apt-get install subversion build-essential libncurses5-dev zlib1g-dev gawk flex git-core gcc-multilib gettext qemu-system-mips quilt mercurial bzr cvs libxml-parser-perl cvs libssl-dev xsltproc
Код:
git clone https://github.com/lede-project/source.git
Код:
cd ~/source
Код:
./scripts/feeds update -a
./scripts/feeds install -a
Но когда выполняю эту команду, то все равно та же ошибка:
Код:
sana@sana ~/source $ make defconfig
Collecting package info: done
WARNING: Makefile 'package/feeds/telephony/freeswitch/Makefile' has a dependency on 'flite', which does not exist
#
# configuration written to .config
#
Пробовал уже раза 3 все по новой, придется видимо к доктору - на выпрямление конечностей..
sana555 вне форума   Ответить с цитированием
Старый 08.02.2018, 15:53   #99
sunny
Senior Member
 
Аватар для sunny
 
Регистрация: 22.10.2015
Адрес: Там где сосны и песок
Сообщений: 1,534
Вес репутации: 1598
sunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to all
По умолчанию

Все верно, это я поторопился, мне там в другом месте один "товарищ" нервы накрутил ...
Код:
sudo apt-get install -f
Поправил если вдруг кто сюда зайдет и решит воспользоваться...
Это ерунда:
Код:
WARNING: Makefile 'package/feeds/telephony/freeswitch/Makefile' has a dependency on 'flite', which does not exist
Касается кривого makefile для конкретного пакета 'flite', это косяк разработчиков, не ваш... так бывает и не редко..
Хотя я бы собирал транк и отсюда:
Код:
git clone https://github.com/openwrt/openwrt.git
cd ./openwrt
./scripts/feeds update -a
./scripts/feeds install -a
make defconfig
make prereq
make menuconfig

(4-х ядерный процессор ПК -/+35 минут)
make -j5 V=s
или
(2-х ядерный процессор ПК -/+70 минут)
make -j3 V=s
или
make V=s
__________________
Читаю ваши мысли по аватару ...

Последний раз редактировалось sunny; 08.02.2018 в 19:30.
sunny вне форума   Ответить с цитированием
Старый 08.02.2018, 16:07   #100
sana555
Senior Member
 
Регистрация: 22.09.2017
Сообщений: 338
Вес репутации: 439
sana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to beholdsana555 is a splendid one to behold
По умолчанию

Цитата:
Сообщение от sunny Посмотреть сообщение
Хотя я бы собирал транк и отсюда:
Хорошо, сейчас для openwrt попробую.
sana555 вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 13:48. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd. Перевод: zCarot
Яндекс.Метрика