Форум обсуждения оборудования  

Вернуться   Форум обсуждения оборудования "Умный дом" > Форум умного дома > Сделай сам > Linux для начинающих

Ответ
 
Опции темы Поиск в этой теме Опции просмотра
Старый 10.08.2017, 11:57   #281
sakatgg
Senior Member
 
Регистрация: 15.07.2014
Сообщений: 870
Вес репутации: 914
sakatgg is just really nicesakatgg is just really nicesakatgg is just really nicesakatgg is just really nicesakatgg is just really nice
По умолчанию

Скомпилился ptokax 0.5.2.2 Проверяем. Сам не скоро наверное проверю. Приложил заодно зависимые пакеты и feed для Lede

ptokax - кросс-компиляция на Lede

Добавляем в feeds.conf.default
src-git rtndev https://github.com/Entware-ng/rtndev.git

./scripts/feeds update -a
./scripts/feeds install -a

Заменяем папку feed/rtndev/ptokax/ на изменённый под Lede из архива

В make menuconfig
Включаем
Код:
Network-> P2P -> ptokax
Libraries -> libiconv-full
В Global build settings

Включаем
Код:
Compile with full language support
Ставим в None
Код:
Stack-Smashing Protection
Enable buffer-overflows detection (FORTIFY_SOURCE)
Enable RELRO protection
P.S.
По этому методу не запускается ptokax,
ошибка в логе осталась
Код:
Mon Apr 17 16:17:18 2017 - TextConverter iconv_open for m_iconvAsciiToUtf failed!
так что пока пользуемся инструкцией, с патчем (без libiconv) под Lede отсюда.
Вложения
Тип файла: zip ptokax 0.5.2.2 feed package for Lede (rev 08.08.17).zip (1,010.7 Кб, 14 просмотров)

Последний раз редактировалось sakatgg; 12.08.2017 в 22:16. Причина: Пользуемся старой инструкцией
sakatgg вне форума   Ответить с цитированием
Старый 10.08.2017, 13:09   #282
dcbeelinekz
Member
 
Аватар для dcbeelinekz
 
Регистрация: 31.03.2017
Сообщений: 49
Вес репутации: 0
dcbeelinekz is an unknown quantity at this point
По умолчанию

Цитата:
Сообщение от sakatgg Посмотреть сообщение
Скомпилился ptokax 0.5.2.2 Проверяем. Сам не скоро наверное проверю. Приложил заодно зависимые пакеты и feed для Lede
При установке пакета, сразу запускается:
Starting PtokaX DC Hub 0.5.2.2 as daemon using /root/.PtokaX as config directory.

И вот такая ошибка в логе:
Thu Aug 10 15:59:37 2017 - TextConverter iconv_open for m_iconvAsciiToUtf failed!

libiconv-full_1.11.1-3_mips_24kc.ipk установил
Свой Settings.pxt в папку с конфигом закинул
dcbeelinekz вне форума   Ответить с цитированием
Старый 10.08.2017, 13:41   #283
Александр Рыжов
Junior Member
 
Регистрация: 08.08.2017
Сообщений: 25
Вес репутации: 0
Александр Рыжов is an unknown quantity at this point
По умолчанию

@dcbeelinekz, приведите вывод
Код:
ldd `which PtokaX`
Александр Рыжов вне форума   Ответить с цитированием
Старый 10.08.2017, 13:48   #284
dcbeelinekz
Member
 
Аватар для dcbeelinekz
 
Регистрация: 31.03.2017
Сообщений: 49
Вес репутации: 0
dcbeelinekz is an unknown quantity at this point
По умолчанию

Цитата:
Сообщение от Александр Рыжов Посмотреть сообщение
@dcbeelinekz, приведите вывод
Код:
ldd `which PtokaX`
Пожалуйста

root@LEDE:~# ldd `which PtokaX`
Код:
        /lib/ld-musl-mips-sf.so.1 (0x56366000)
        libiconv.so.2 => /usr/lib/libiconv.so.2 (0x77954000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x77802000)
        liblua.so.5.1.5 => /usr/lib/liblua.so.5.1.5 (0x777d4000)
        libz.so.1 => /usr/lib/libz.so.1 (0x777b4000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x77790000)
        libc.so => /lib/ld-musl-mips-sf.so.1 (0x56366000)
dcbeelinekz вне форума   Ответить с цитированием
Старый 10.08.2017, 14:54   #285
sakatgg
Senior Member
 
Регистрация: 15.07.2014
Сообщений: 870
Вес репутации: 914
sakatgg is just really nicesakatgg is just really nicesakatgg is just really nicesakatgg is just really nicesakatgg is just really nice
По умолчанию

Собрал полностью прошивку Netgear wndr3800 , такая же ошибка в логе
Код:
Mon Apr 17 16:17:18 2017 - TextConverter iconv_open for m_iconvAsciiToUtf failed!

ldd `which PtokaX`

Код:
BusyBox v1.25.1 () built-in shell (ash)

     _________
    /        /\      _    ___ ___  ___
   /  LE    /  \    | |  | __|   \| __|
  /    DE  /    \   | |__| _|| |) | _|
 /________/  LE  \  |____|___|___/|___|                      lede-project.org
 \        \   DE /
  \    LE  \    /  -----------------------------------------------------------
   \  DE    \  /    Reboot (17.01.1, r3316-7eb58cf109)
    \________\/    -----------------------------------------------------------

root@LEDE:~#
root@LEDE:~# ldd `which PtokaX`
        /lib/ld-musl-mips-sf.so.1 (0x5646a000)
        libiconv.so.2 => /usr/lib/libiconv.so.2 (0x77f80000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x77e2e000)
        liblua.so.5.1.5 => /usr/lib/liblua.so.5.1.5 (0x77e00000)
        libz.so.1 => /usr/lib/libz.so.1 (0x77de0000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x77dbc000)
        libc.so => /lib/ld-musl-mips-sf.so.1 (0x5646a000)
root@LEDE:~#
[свернуть]

Последний раз редактировалось sakatgg; 10.08.2017 в 15:01.
sakatgg вне форума   Ответить с цитированием
Старый 10.08.2017, 18:19   #286
d.nokman
Junior Member
 
Регистрация: 10.08.2017
Сообщений: 13
Вес репутации: 0
d.nokman is an unknown quantity at this point
По умолчанию

Всем доброго времени суток!
Прошу прощения за достаточно наивный вопрос, т.к. я в этом полный чайник.
ОС Ubuntu 16.04 в VirtualBox
Пытаюсь скомпилировать пакет для СС 15.05.1
Ситуация в следующем - компиляция (~/openwrt$ make package/test/compile V=s) завершается с ошибкой:
Код:
build_dir/target-mips_34kc_glibc-2.21/toolchain/ipkg-ar71xx/libgcc/lib/
cp: cannot stat '/home/uuu/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_glibc-2.21/lib/libgcc_s.so.*': No such file or directory
Makefile:637: recipe for target '/home/uuu/openwrt/bin/ar71xx-glibc/packages/base/libgcc_unknown-1_ar71xx.ipk' failed
В make "menuconfig" выбрано glibc 2.21 (при uClibc ситуация в принципе аналогичная, только ругается на другие библиотеки).

не знаю имеет это отношение к делу или нет, но "apt list *libc*" выдает:
Код:
...
libc6-dev/xenial-updates,xenial-security,now 2.23-0ubuntu9 i386 [установлен]
libc6-dev-amd64/xenial-updates,xenial-security,now 2.23-0ubuntu9 i386 [установлен, автоматически]
libc6-dev-arm64-cross/xenial 2.23-0ubuntu3cross1 all
libc6-dev-armel-armhf-cross/xenial 2.23-0ubuntu3cross1 all
libc6-dev-armel-cross/xenial 2.23-0ubuntu3cross1 all
libc6-dev-armhf-armel-cross/xenial 2.23-0ubuntu3cross1 all
...
Архитектуры пытался взять разные (т.к. пока только пробую), результат одинаковый - эта ошибка.
Подскажите в какую сторону копать, очень хочется разобраться.
Спасибо.

Чую, что дело в библиотеках С, но не знаю как исправить ситуацию...
d.nokman вне форума   Ответить с цитированием
Старый 10.08.2017, 21:36   #287
sakatgg
Senior Member
 
Регистрация: 15.07.2014
Сообщений: 870
Вес репутации: 914
sakatgg is just really nicesakatgg is just really nicesakatgg is just really nicesakatgg is just really nicesakatgg is just really nice
По умолчанию

d.nokman
Цитата:
cp: cannot stat '/home/uuu/openwrt/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_glibc-2.21/lib/libgcc_s.so.*': No such file or directory
смотри почему нет файлов libgcc_s.so и libgcc_s.so.1

Warning смотри в выводе компилятора, мож указания есть на нужные либы, отсутствующие в системе

Последний раз редактировалось sakatgg; 10.08.2017 в 22:08.
sakatgg вне форума   Ответить с цитированием
Старый 10.08.2017, 22:33   #288
d.nokman
Junior Member
 
Регистрация: 10.08.2017
Сообщений: 13
Вес репутации: 0
d.nokman is an unknown quantity at this point
По умолчанию

Цитата:
Сообщение от sakatgg Посмотреть сообщение

смотри почему нет файлов libgcc_s.so и libgcc_s.so.1

Warning смотри в выводе компилятора, мож указания есть на нужные либы, отсутствующие в системе
>смотри в выводе компилятора
это как?
если вывод компилятора это результат работы команды make на экране, то ничего внятного больше нет. Вопрос в том, какие конкретно недостающие библиотеки для кросс компиляции надо поставить, как я понимаю дело именно в них...
d.nokman вне форума   Ответить с цитированием
Старый 10.08.2017, 22:55   #289
sakatgg
Senior Member
 
Регистрация: 15.07.2014
Сообщений: 870
Вес репутации: 914
sakatgg is just really nicesakatgg is just really nicesakatgg is just really nicesakatgg is just really nicesakatgg is just really nice
По умолчанию

Цитата:
если вывод компилятора это результат работы команды make на экране
Да

Можешь здесь глянуть Сообщение 720241 какие пакеты у меня стоят, правда для х64

Последний раз редактировалось sakatgg; 10.08.2017 в 23:00.
sakatgg вне форума   Ответить с цитированием
Старый 11.08.2017, 08:44   #290
Александр Рыжов
Junior Member
 
Регистрация: 08.08.2017
Сообщений: 25
Вес репутации: 0
Александр Рыжов is an unknown quantity at this point
По умолчанию

Цитата:
Сообщение от dcbeelinekz Посмотреть сообщение
Пожалуйста

root@LEDE:~# ldd `which PtokaX`
Код:
        /lib/ld-musl-mips-sf.so.1 (0x56366000)
        libiconv.so.2 => /usr/lib/libiconv.so.2 (0x77954000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x77802000)
        liblua.so.5.1.5 => /usr/lib/liblua.so.5.1.5 (0x777d4000)
        libz.so.1 => /usr/lib/libz.so.1 (0x777b4000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x77790000)
        libc.so => /lib/ld-musl-mips-sf.so.1 (0x56366000)
Спасибо. Последний вопрос: libiconv.so приехала из стандартного репозитория LEDE? (см. opkg list_installed). Если да, и собрана она там как заглушка, то придётся:
1) либо отказаться от конвертации ascii<->utf8 в PtokaX,
2) либо устанавливать вместе с PtokaX свой, полный вариант libiconv, игнорируя ругань opkg на зависимости:
Код:
opkg --force-depends remove libiconv
opkg install ./libiconv-full_1.11.1-3_mips_24kc.ipk
Александр Рыжов вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 3 (пользователей: 0 , гостей: 3)
 
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 06:49. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd. Перевод: zCarot
Яндекс.Метрика