Форум обсуждения оборудования  

Вернуться   Форум обсуждения оборудования "Умный дом" > Форум умного дома > Сделай сам > CyberWrt

Ответ
 
Опции темы Поиск в этой теме Опции просмотра
Старый 22.11.2017, 12:37   #451
_Валерий_
Junior Member
 
Регистрация: 21.11.2017
Сообщений: 8
Вес репутации: 0
_Валерий_ is an unknown quantity at this point
По умолчанию

Цитата:
Сообщение от Admin Посмотреть сообщение
А без роутера пробовали команды отправлять ардуине?
Например: cm=W
Только что попробовал отправлять на ардуино без роутера. Смотрел встроенным монитором порта в ARDUINO IDE на 57600
Если использовать скетч с cyberlib, то после загрузки выдает в порт показания датчиков бесконечно.
Загрузил скетч, который без этой библиотеки, раскоментировал Serial.println(inByte); //for debug, feedback will not work!
на команды реагирует. ответы посылает
на cm=] откликается 93 {"dat1":"5.07","dat2":"100.00"}
на cm=W откликается 87
Т.е. все правильно. Буквы по кодировке верны
Чутка ошибся. поправил

Последний раз редактировалось _Валерий_; 22.11.2017 в 13:47.
_Валерий_ вне форума   Ответить с цитированием
Старый 22.11.2017, 16:57   #452
DAndrey
Junior Member
 
Регистрация: 06.10.2016
Сообщений: 10
Вес репутации: 0
DAndrey is an unknown quantity at this point
По умолчанию

файлы. Права на папки 755. ...Попробуй волшебную кнопку в различных вариантах, авось поможет. Место на диске имеется?
Миниатюры
Нажмите на изображение для увеличения
Название: 2 - копия.gif
Просмотров: 164
Размер:	37.3 Кб
ID:	4590  

Последний раз редактировалось DAndrey; 22.11.2017 в 17:12.
DAndrey вне форума   Ответить с цитированием
Старый 22.11.2017, 18:35   #453
_Валерий_
Junior Member
 
Регистрация: 21.11.2017
Сообщений: 8
Вес репутации: 0
_Валерий_ is an unknown quantity at this point
По умолчанию

Файлы соответствуют. Волшебную кнопку пробовал. Даже не поленился сейчас с нуля переставил CyberWrt/ Место вроде есть там 500+ кб в наличии.
Сделал еще одну вещь. Вручную отредактировал www/modules/CyberBot3/set.ini. Там как раз прописывается порт куда ардуинка подключена.
port=ttyATH0
kDat1=1
kDat2=1
conwidth=361
conheight=183
conpos=-7
speed=4
Подключаю к роутеру переходник UART-USB. USB в комп. Открываю PuTTY. Вижу что от роутера приходит " cm=] "
Подключаю ардуинку к UART, USB в комп и смотрю что она шлет через сериал монитор. Она отправляет показания датчиков, соответственно "cm=]" принимает, распознает и отвечает норм. Если закрыть модель кибер бота, обмен данными прекращается.
На нажатие всего другого в модуле, реакции никакой
В общем я так понимаю что по железу все ок. Почему то сам модуль CyberBot3 не загружается до конца, ну или нажатие кнопок не выполняется по какой то причине

Последний раз редактировалось _Валерий_; 22.11.2017 в 18:41.
_Валерий_ вне форума   Ответить с цитированием
Старый 22.11.2017, 19:06   #454
DAndrey
Junior Member
 
Регистрация: 06.10.2016
Сообщений: 10
Вес репутации: 0
DAndrey is an unknown quantity at this point
По умолчанию

Попробуй для разнообразия другие браузера Оперу, Лиса........
DAndrey вне форума   Ответить с цитированием
Старый 23.11.2017, 18:44   #455
_Валерий_
Junior Member
 
Регистрация: 21.11.2017
Сообщений: 8
Вес репутации: 0
_Валерий_ is an unknown quantity at this point
По умолчанию

то DAndrey
Смена браузеров не помогла к сожалению. Если не секрет у тебя на каком роутере все это стоит? Я просто подумал - может с железом роутера что то не то. Может мне на других моделях поэксперементировать . На некс можно попробовать, он даже немного компактнее.
Ну и уж совсем глупая идея - Может из софта для винды чего надо? Хотя ява вроде стоит, для PHP вроде совсем не надо ничего
_Валерий_ вне форума   Ответить с цитированием
Старый 23.11.2017, 19:58   #456
Admin
Administrator
 
Аватар для Admin
 
Регистрация: 12.04.2010
Адрес: Москва
Сообщений: 9,273
Вес репутации: 9472
Admin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant futureAdmin has a brilliant future
По умолчанию

Первые две версии писались и тестировались на mr3020. 3-ю версию я отлаживал на Next
Admin на форуме   Ответить с цитированием
Старый 25.11.2017, 08:07   #457
DAndrey
Junior Member
 
Регистрация: 06.10.2016
Сообщений: 10
Вес репутации: 0
DAndrey is an unknown quantity at this point
По умолчанию

Стоит на MR3020.

Развернуть для просмотра

Текущая Дата и время
Sat Nov 25 09:55:02 EKAT 2017
Версия прошивки
Linux version 3.10.4 (cyberwrt@cyberwrt) (gcc version 4.6.4 (OpenWrt/Linaro GCC 4.6-2012.12 r37816) ) #1 Mon Nov 25 16:28:55 MSK 2013
Информация о CPU
system type : Atheros AR9330 rev 1
machine : TP-LINK TL-MR3020
processor : 0
cpu model : MIPS 24Kc V7.4
BogoMIPS : 265.42
wait instruction : yes
microsecond timers : yes
tlb_entries : 16
extra interrupt vector : yes
hardware watchpoint : yes, count: 4, address/irw mask: [0x0000, 0x0ff8, 0x0ff8, 0x0ff8]
isa : mips1 mips2 mips32r1 mips32r2
ASEs implemented : mips16
shadow register sets : 1
kscratch registers : 0
core : 0
VCED exceptions : not available
VCEI exceptions : not available
Информация о RAM
MemTotal: 28940 kB
MemFree: 3596 kB
Buffers: 2676 kB
Cached: 7376 kB
SwapCached: 4 kB
Active: 5468 kB
Inactive: 5988 kB
Active(anon): 788 kB
Inactive(anon): 1472 kB
Active(file): 4680 kB
Inactive(file): 4516 kB
Unevictable: 0 kB
Mlocked: 0 kB
SwapTotal: 32764 kB
SwapFree: 32760 kB
Dirty: 0 kB
Writeback: 0 kB
AnonPages: 1416 kB
Mapped: 1484 kB
Shmem: 856 kB
Slab: 8408 kB
SReclaimable: 4372 kB
SUnreclaim: 4036 kB
KernelStack: 296 kB
PageTables: 216 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 47232 kB
Committed_AS: 4804 kB
VmallocTotal: 1048372 kB
VmallocUsed: 816 kB
VmallocChunk: 1041476 kB
Зарезервированые области памяти
00000000-01ffffff : System RAM
00060000-002a06e3 : Kernel code
002a06e4-003371bb : Kernel data
18020000-180200ff : ar933x-uart
18060008-1806000f : ath79-wdt
18060008-1806000f : ath79-wdt
18100000-1811ffff : ar933x_wmac
19000000-190001ff : mac_base
1a000000-1a0001ff : mdio_base
1b000000-1b000fff : ehci-platform
1b000000-1b000fff : ehci-platform
1f000000-1fffffff : ath79-spi
Информация об используемой и свободной ОЗУ и Swap
total used free shared buffers
Mem: 28940 25348 3592 0 2676
-/+ buffers: 22672 6268
Swap: 32764 4 32760
Свободное и используемое место в разделах
Filesystem Size Used Available Use% Mounted on
rootfs 895.9M 18.9M 814.6M 2% /
/dev/root 1.5M 1.5M 0 100% /rom
tmpfs 14.1M 860.0K 13.3M 6% /tmp
/dev/sda1 895.9M 18.9M 814.6M 2% /overlay
overlayfs:/overlay 895.9M 18.9M 814.6M 2% /
tmpfs 512.0K 0 512.0K 0% /dev
Используемые системой GPIO
GPIOs 0-29, ath79:
gpio-0 (tp-link:green:wlan ) out hi
gpio-8 (USB power ) out hi
gpio-11 (wps ) in lo
gpio-17 (tp-link:green:lan ) out hi
gpio-18 (sw1 ) in hi
gpio-20 (sw2 ) in lo
gpio-26 (tp-link:green:wps ) out hi
gpio-27 (tp-link:green:3g ) out hi
Информация о сетевых устройствах
br-lan Link encap:Ethernet HWaddr C4:6E:1F:**:**:**
inet addr:192.168.100.100 Bcast:192.168.100.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

eth0 Link encap:Ethernet HWaddr C4:6E:1F:**:**:**
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:4

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:18940 errors:0 dropped:0 overruns:0 frame:0
TX packets:18940 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1912563 (1.8 MiB) TX bytes:1912563 (1.8 MiB)

wlan0 Link encap:Ethernet HWaddr 00:2A:3A:**:**:**
inet addr:192.168.2.100 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:550282 errors:0 dropped:10703 overruns:0 frame:0
TX packets:42027 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:27567330 (26.2 MiB) TX bytes:5357548 (5.1 MiB)
Настройки WiFi адаптера
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option path 'platform/ar933x_wmac'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option country 'JP'
option txpower '20'
option channel 'auto'

config wifi-iface
option network 'wwan'
option device 'radio0'
option mode 'sta'
option bssid '90:F6:52:**:**:**'
option key 'qwertyuiop[]'
option macaddr '00:2a:3a:**:**:**'
option encryption 'psk+tkip+aes'
option ssid 'TP-LINK'
Настройки сети
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdc9:57d4:1afa::/48'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
option ipaddr '192.168.100.100'
option dns '213.135.97.131'

config interface 'wwan'
option ipaddr '192.168.2.100'
option netmask '255.255.255.0'
option gateway '192.168.2.1'
option dns '213.135.97.131'
option proto 'static'
Параметры UART порта
speed 57600 baud; rows 0; columns 0; line = 0;
intr = ; quit = ; erase = ; kill = ; eof = ;
eol = ; eol2 = ; swtch = ; start = ; stop = ;
susp = ; rprnt = ; werase = ; lnext = ;
flush = ; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon -ixoff
-iuclc -ixany -imaxbel -iutf8
-opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
-isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop -echoprt
-echoctl -echoke
Список установленных пакетов
alsa-lib - 1.0.27.2-1
base-files - 146-r37816
block-mount - 2013-08-16.1-5290ec879aa4d9f4192df00aad4434b0f0afa872
busybox - 1.19.4-7
coreutils - 8.16-1
coreutils-stty - 8.16-1
directfb - 1.4.2-1
dnsmasq - 2.66-3
dropbear - 2012.55-2
e2fsprogs - 1.42.4-1
fdisk - 2.21.2-2
glib2 - 2.37.7-1
iw - 3.10-1
iwinfo - 46
jshn - 2013-08-01-04f194aa8a04926fe7f2e42bbf9ba6c62d49339e
kernel - 3.10.4-1-6910dd36396650e8ef41514cdbde550a
kmod-ath - 3.10.4+2013-06-27-1
kmod-ath9k - 3.10.4+2013-06-27-1
kmod-ath9k-common - 3.10.4+2013-06-27-1
kmod-cfg80211 - 3.10.4+2013-06-27-1
kmod-crypto-aes - 3.10.4-1
kmod-crypto-arc4 - 3.10.4-1
kmod-crypto-core - 3.10.4-1
kmod-crypto-hash - 3.10.4-1
kmod-crypto-manager - 3.10.4-1
kmod-fs-ext4 - 3.10.4-1
kmod-fs-vfat - 3.10.4-1
kmod-fuse - 3.10.4-1
kmod-gpio-button-hotplug - 3.10.4-1
kmod-i2c-core - 3.10.4-1
kmod-input-core - 3.10.4-1
kmod-leds-gpio - 3.10.4-1
kmod-ledtrig-default-on - 3.10.4-1
kmod-ledtrig-netdev - 3.10.4-1
kmod-ledtrig-timer - 3.10.4-1
kmod-lib-crc-ccitt - 3.10.4-1
kmod-lib-crc16 - 3.10.4-1
kmod-mac80211 - 3.10.4+2013-06-27-1
kmod-nls-base - 3.10.4-1
kmod-nls-iso8859-1 - 3.10.4-1
kmod-scsi-core - 3.10.4-1
kmod-sound-core - 3.10.4-1
kmod-usb-audio - 3.10.4-1
kmod-usb-core - 3.10.4-1
kmod-usb-serial - 3.10.4-1
kmod-usb-serial-cp210x - 3.10.4-1
kmod-usb-storage - 3.10.4-1
kmod-usb2 - 3.10.4-1
kmod-video-core - 3.10.4-1
kmod-video-uvc - 3.10.4-1
kmod-video-videobuf2 - 3.10.4-1
libblkid - 2.21.2-2
libblobmsg-json - 2013-08-01-04f194aa8a04926fe7f2e42bbf9ba6c62d49339e
libbz2 - 1.0.6-1
libc - 0.9.33.2-1
libelf1 - 0.155-1
libext2fs - 1.42.4-1
libffi - 3.0.11-1
libfreetype - 2.4.8-1
libgcc - 4.6-linaro-1
libiw - 29-5
libiwinfo - 46
libiwinfo-lua - 46
libjpeg - 6b-1
libjson-c - 0.11-2
libjson-script - 2013-08-01-04f194aa8a04926fe7f2e42bbf9ba6c62d49339e
liblua - 5.1.5-1
libmikmod - 3.1.12-3
libncurses - 5.9-1
libnl-tiny - 0.1-3
libogg - 1.3.1-1
libpng - 1.2.50-1
libpthread - 0.9.33.2-1
librpc - 0.9.32-rc2-0a2179bbc0844928f2a0ec01dba93d9b5d6d41a7
librt - 0.9.33.2-1
libsdl - 1.2.14-2
libsdl-mixer - 1.2.11-1
libsysfs - 2.1.0-2
libubox - 2013-08-01-04f194aa8a04926fe7f2e42bbf9ba6c62d49339e
libubus - 2013-08-08-b20a8a01c7faea5bcc9d34d10dcf7736589021b8
libubus-lua - 2013-08-08-b20a8a01c7faea5bcc9d34d10dcf7736589021b8
libuci - 2013-06-11.1-1
libuci-lua - 2013-06-11.1-1
libuuid - 2.21.2-2
libvorbisidec - 1.0.2+svn18153-1
lua - 5.1.5-1
luci-app-samba - svn-r9933-1
luci-i18n-english - svn-r9933-1
luci-i18n-russian - svn-r9933-1
luci-lib-core - svn-r9933-1
luci-lib-ipkg - svn-r9933-1
luci-lib-nixio - svn-r9933-1
luci-lib-sys - svn-r9933-1
luci-lib-web - svn-r9933-1
luci-mod-admin-core - svn-r9933-1
luci-mod-admin-full - svn-r9933-1
luci-proto-core - svn-r9933-1
luci-sgi-cgi - svn-r9933-1
luci-theme-base - svn-r9933-1
luci-theme-openwrt - svn-r9933-1
mc - 4.8.10-1
microcom - 1.02-1
minicom - 2.3-1
mjpg-streamer - r181-1
mtd - 20
netifd - 2013-07-16-2674941b06c1ec67f1aff1bff9212e1372106641
ntfs-3g - 2011.4.12-1-fuseint
opkg - 618-3
procd - 2013-08-16-85a5ce27f5f02e4ddab6916d69ba7f7375d289d4-1
pure-ftpd - 1.0.36-1
recmic - 1-1
samba36-server - 3.6.11-2
serp - 1-1
terminfo - 5.9-1
uboot-envtools - 2013.07-rc1-2
ubox - 2013-08-16.1-5290ec879aa4d9f4192df00aad4434b0f0afa872
ubus - 2013-08-08-b20a8a01c7faea5bcc9d34d10dcf7736589021b8
ubusd - 2013-08-08-b20a8a01c7faea5bcc9d34d10dcf7736589021b8
uci - 2013-06-11.1-1
uhttpd - 2013-07-31-fae8886f8aa5d996c8de607abea8b677216549b5
wpad-mini - 20130807-1
zlib - 1.2.8-1
Глобальные переменые
SERVER_SOFTWARE = uhttpd
SERVER_NAME = 192.168.2.100
GATEWAY_INTERFACE = CGI/1.1
SERVER_PROTOCOL = HTTP/1.1
SERVER_PORT = 80
SERVER_ADMIN =
SERVER_SIGNATURE =
REQUEST_URI = /cgi-bin/modules/about/index.cgi
REQUEST_METHOD = GET
QUERY_STRING =
REMOTE_HOST = 192.168.2.4
REMOTE_ADDR = 192.168.2.4
HTTP_ACCEPT = text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8
HTTP_HOST = 192.168.2.100
HTTP_USER_AGENT = Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.59 Safari/537.36
SCRIPT_NAME = /cgi-bin/modules/about/index.cgi
SCRIPT_FILENAME = /www/cgi-bin/modules/about/index.cgi
PATH = /sbin:/usr/sbin:/bin:/usr/bin
PATH_INFO =
PATH_TRANSLATED =
REMOTE_USER = admin
AUTH_TYPE =
CONTENT_TYPE =
CONTENT_LENGTH =
[свернуть]

Последний раз редактировалось DAndrey; 25.11.2017 в 08:11.
DAndrey вне форума   Ответить с цитированием
Старый 25.11.2017, 14:27   #458
sunny
Senior Member
 
Аватар для sunny
 
Регистрация: 22.10.2015
Адрес: Там где сосны и песок
Сообщений: 1,393
Вес репутации: 1453
sunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to all
По умолчанию

По моему тут надо разобраться, как реализован интерфейс - что за код (java или еще чего).

Соответственно - браузер и/или ОС ПК не имеет поддержки данного кода для отображения, либо блокируют сторонние плагины навроде Adblock Noscript.
Не первый раз вижу на форуме тему с отсутствием отображения данного веб интерфейса.
Прошивку создавали во время повсеместного флеш, про hmtl5 тогда еще..
Имхо - причина где здесь (я не программист, точно не скажу)
===
По железу - проверяйте напряжение питания под нагрузкой - не должно быть просадок напряжения...
__________________
Читаю ваши мысли по аватару ...

Последний раз редактировалось sunny; 25.11.2017 в 14:30.
sunny вне форума   Ответить с цитированием
Старый 01.12.2017, 15:23   #459
_Валерий_
Junior Member
 
Регистрация: 21.11.2017
Сообщений: 8
Вес репутации: 0
_Валерий_ is an unknown quantity at this point
По умолчанию

Цитата:
Сообщение от sunny Посмотреть сообщение
По моему тут надо разобраться, как реализован интерфейс - что за код (java или еще чего).

Соответственно - браузер и/или ОС ПК не имеет поддержки данного кода для отображения, либо блокируют сторонние плагины навроде Adblock Noscript.
Похоже на то. Запустил кибер бота в IE. Он видит следующие ошибки:

Развернуть для просмотра





[свернуть]

Попробовал открыть файл/modules/CyberBot3/carduino.spybot.js через модуль файлового менеджера. там иероглифы одни

Последний раз редактировалось _Валерий_; 01.12.2017 в 15:25.
_Валерий_ вне форума   Ответить с цитированием
Старый 01.12.2017, 16:27   #460
sunny
Senior Member
 
Аватар для sunny
 
Регистрация: 22.10.2015
Адрес: Там где сосны и песок
Сообщений: 1,393
Вес репутации: 1453
sunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to allsunny is a name known to all
По умолчанию

_Валерий_
Что-то из Native Language Support отсутствует, надо пакет с различными кодировками поставить - может "взлетит"
__________________
Читаю ваши мысли по аватару ...
sunny вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 2 (пользователей: 0 , гостей: 2)
 
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 18:43. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd. Перевод: zCarot
Яндекс.Метрика