Форум обсуждения систем  

Вернуться   Форум обсуждения систем "Умный дом", проектов Ардуино, OpenWRT и других DIY устройств > Форум умного дома > Сделай сам > OpenWRT/LEDE

Ответ
 
Опции темы Поиск в этой теме Опции просмотра
Старый 03.06.2019, 12:28   #1
raconteur
Junior Member
 
Регистрация: 18.02.2018
Адрес: Krasnodar
Сообщений: 6
Вес репутации: 0
raconteur is an unknown quantity at this point
По умолчанию mr3020, mr3420: 4G, PPTP.

Друзья, возникла задача, организация локалки в загородном доме с возможностью управления некоторыми элементами в локальной сети. В гараже наткнулся на давно заброшенные 2 роутера mr3020 и mr3420. Готовые прошивки не подходили, потому как места в флэшке для всех необходимых модулей не хватало. Перепаивать флэшку не хотелось.
Через ImageBuilder подобрал необходимый минимум пакетов и все работает.
С чем возился очень долго?
1. Научить роутер сразу инициировать соединение с мобильным оператором оказалось самым простым. После загрузки необходимых модулей модем автоматически включался
2. поднятие PPTP вызвало некоторые проблемы
root@LEDE:~# cat /etc/ppp/options.pptp
name toAlex
remotename userPPtP
noipdefault
noauth
nobsdcomp
nodeflate
idle 0
nomppe
nodeflate
hide-password
noproxyarp
maxfail 0
usepeerdns
persist

root@LEDE:~# cat /etc/ppp/peers/toAlex
pty "pptp XXX.XXX.XXX.XXX --nolaunchpppd"
mppe required,no40,no56,stateless
name toAlex
remotename userPPtP
file /etc/ppp/options.pptp

root@LEDE:~# cat /etc/ppp/chap-secrets
#USERNAME PROVIDER PASSWORD IPADDRESS
userPPtP * passwordPPtP *

root@LEDE:~# cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdbe:c15b:9ac9::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth1'
option proto 'static'
option ipaddr '192.168.4.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'

config interface 'wan_4G'
option ifname 'eth2'
option proto 'dhcp'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'

config interface 'toAlex'
option ifname 'eth2'
option proto 'pptp'
option username 'PPtP'
option password '12345'
option server 'XXX.XXX.XXX.XXX'
# option 'buffering' '1'
option mtu '1420'

3. Следующее я искал очень долго и не мог понять как изменить.
после старта маршрутизатора подымается PPtP тоннель и весь трафик шел через него, а мне не нужно этого. После удаления ручками дефолтных маршрутов и снова их прописывая все работало как нужно, но... после перезагрузки, нужно лезть и править или сделать скрипт, который это делает (я кстати большую часть в эту сторону и смотрел).
Затем я обратил свой взор к стартовым скриптам
root@LEDE:/lib/netifd# ls -lsa /lib/netifd/
0 drwxr-xr-x 1 root root 0 Jun 3 07:57 .
0 drwxr-xr-x 1 root root 0 Jun 3 07:57 ..
3 -rwxr-xr-x 1 root root 2645 Nov 16 2018 dhcp.script
21 -rw-r--r-- 1 root root 21142 Jun 2 13:24 hostapd.sh
8 -rw-r--r-- 1 root root 8452 Nov 16 2018 netifd-proto.sh
6 -rw-r--r-- 1 root root 6094 Nov 16 2018 netifd-wireless.sh
0 -rwxr-xr-x 1 root root 238 Jul 20 2018 ppp-down
1 -rwxr-xr-x 1 root root 552 Jun 3 08:10 ppp-up
1 -rwxr-xr-x 1 root root 833 Jul 20 2018 ppp6-up
0 drwxr-xr-x 2 root root 44 Jun 3 07:57 proto
1 -rw-r--r-- 1 root root 761 Nov 16 2018 utils.sh
0 drwxr-xr-x 2 root root 34 Jun 3 07:57 wireless

нас интересует скрипт ppp-up, в частности строчка о маршруте с метрикой
[ -n "$IPREMOTE" ] && proto_add_ipv4_route 0.0.0.0 0 "$IPREMOTE"
После изменения метрики на любую цифру отличную от нуля все стало работать, как мне нужно
я сделал так [ -n "$IPREMOTE" ] && proto_add_ipv4_route 0.0.0.0 10 "$IPREMOTE"
на стороне сервера я сделал маршрут в локалку через это соединение и все стало работать отлично.
Теперь жду как это связка перенесет кубанскую жару

P.S. Странно но прошивки не вложились

Последний раз редактировалось raconteur; 03.06.2019 в 12:32. Причина: отсутствуют вложения
raconteur вне форума   Ответить с цитированием
Старый 03.06.2019, 14:20   #2
paulerr
Senior Member
 
Регистрация: 04.01.2013
Адрес: Москва
Сообщений: 457
Вес репутации: 1143
paulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond reputepaulerr has a reputation beyond repute
По умолчанию

Цитата:
Сообщение от raconteur Посмотреть сообщение
...после старта маршрутизатора подымается PPtP тоннель и весь трафик шел через него, а мне не нужно этого.
...
В конфиге /etc/network для секции VPN-PPTP надо добавить
Код:
	option defaultroute '0'
В каталоге /etc/ppp для клиента можно создать каталог /etc/ppp/ip-up.d и в нем файлы ip-up и ip-down и в них прописать что делать при поднятии/опускании сервиса PPTP

PS. /etc/ppp/ip-up.d - это для клиента в 18.06, в LEDE 17.06 может быть по другому.
PSS. посмотрите на старый wiki openwrt по pptp, там все описано.
paulerr вне форума   Ответить с цитированием
Старый 03.06.2019, 18:33   #3
raconteur
Junior Member
 
Регистрация: 18.02.2018
Адрес: Krasnodar
Сообщений: 6
Вес репутации: 0
raconteur is an unknown quantity at this point
По умолчанию

Цитата:
Сообщение от paulerr Посмотреть сообщение
В конфиге /etc/network для секции VPN-PPTP надо добавить
Код:
	option defaultroute '0'
В каталоге /etc/ppp для клиента можно создать каталог /etc/ppp/ip-up.d и в нем файлы ip-up и ip-down и в них прописать что делать при поднятии/опускании сервиса PPTP

PS. /etc/ppp/ip-up.d - это для клиента в 18.06, в LEDE 17.06 может быть по другому.
PSS. посмотрите на старый wiki openwrt по pptp, там все описано.
Я задачу решил. Все работает хорошо и стабильно. Еще думаю, на всякий случай, активировать watchdog. Но это позже
raconteur вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы Поиск в этой теме
Поиск в этой теме:

Расширенный поиск
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 18:29. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd. Перевод: zCarot
Яндекс.Метрика